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CHAPTER 1 CrunchIt Overview
CrunchIt is the most advanced compression utility available for Microsoft Pocket 
PC devices. It offers unparalleled ease-of-use, security features and supports more 
file formats than any other package. 

Supported File Formats
CrunchIt allows you to exchange files with Windows, Macintosh, UNIX and other 
handheld computers. It supports ZIP (.zip), SFX (*.exe), UUE (multipart with stan-
dard and base64 encoding), JAR (.jar), TAR (.tar), GZIP (.tar.gz, .tgz) and BZIP2 
(.bz, .bz2, .tbz, .tbz2) file formats. 

Advanced Navigation

CrunchIt makes working with large archives fast and easy. It organizes information 
so that you can browse information in the same manner as Microsoft File Explorer, 
by working with individual files and folders. In addition, you can search for files 
and view relevant statistics like ‘size on disk,’ plus much more.

Automate Complex Tasks
CrunchIt provides seamless integration with Microsoft File Explorer and other 
Pocket PC applications. When you double tap an archive entry, CrunchIt will auto-
CrunchIt User Guide 1



CrunchIt Overview

2

matically extract and open the file. Or you can harness the power of CrunchIt in 
your scripts by using the command line options (registered version only) to move 
files in and out of archives.

Send Files Fast, Safe And Secure
Use CrunchIt to compress your files and reduce transmission time. You can also 
secure files with CrunchIt to prevent unwanted visitors from snooping through your 
data.

An Excellent Backup Tool
CrunchIt makes it easy to move files in and out of archives. You can add or move 
entire folders into a ZIP file based on age or name (for example, *.doc). Extract 
files with the peace of mind that you will not erase something important.

Create Self-extracting ZIP Files

CrunchIt is an essential tool for software developers. You can create self-extracting 
ZIP files (*.exe) for ARM, XScale, MIPS, SH3 and X86 emulator Pocket PC 
devices. Software deployment has never been easier!

Benchmark Your Pocket PC

See how fast your Pocket PC really is. For enthusiasts and reviewers, use CrunchIt 
to benchmark the performance of your processor and storage devices.
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CHAPTER 2 What’s New?
The latest version of CrunchIt introduces many new navigation and command line 
features that make working with archives faster and easier. 

New Navigation Features
CrunchIt changes the way you interact with archives. It organizes information so 
that you can browse files and folders in the same manner as Microsoft File 
Explorer. In addition, a new navigation toolbar is provided to help you view, find 
and select the files you want.

New Display Modes
CrunchIt 5.0 includes two new display modes: “tall” and “short.” Tall mode shows 
you essential file information and makes it easier to browse and select files. Short 
mode lets you see the maximum number of files on a small display.

Command Line Support (registered version)
Now you can integrate CrunchIt into your own applications. With the new com-
mand line options, you can create Shortcuts, scripts or even make “shell” calls that 
will automatically perform add, test and extract operations without writing your 
own compression software.
CrunchIt User Guide 3
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New SFX Features
Now you can use self-extracting ZIP files to build installation and recovery solu-
tions.  The new command line options and error reporting features lets you simplify 
or eliminate user input!
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CHAPTER 3 System Requirements
The minimum requirements your device needs to run CrunchIt are: 

• A XScale, ARM, MIPS or SH3 processor.
• 16 megabytes (MB) of RAM.
• Color or monochrome display.
• Microsoft Pocket PC 2000/2002 or Windows Mobile 2003 operating system.
• 1 megabyte (MB) of storage for application data; 2 MB or more for temporary 

and archive data.
• External memory cards and storage devices are supported.
CrunchIt User Guide 5
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CHAPTER 4 Installation Notes
This chapter describes the procedures to install and uninstall CrunchIt.

NOTE: It is recommended that you perform a “soft” reset of  the device after 
installing CrunchIt. Refer to your handheld manual for further details.

NOTE: If you have purchased CrunchIt from an on-line distributor, print out your 
receipt and make a back-up copy of the software.

Installing
Perform the following steps to install CrunchIt:

1. Open Microsoft Windows Explorer (Start > Programs > Accessories > Win-
dows Explorer) on your desktop computer.

2. Double-click the Setup.exe icon in the CrunchIt folder.
3. Click the Install.
4. Read the license agreement carefully. If you agree to the terms, click the Accept  

button to launch Microsoft ActiveSync.
5. Follow the on-screen instructions.
6. Verify CrunchIt has been installed on your device by looking in the "Programs" 

folder (Start > Programs > CrunchIt).
CrunchIt User Guide 7
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You can also install CrunchIt on your device:
1. Locate the .CAB file for your device (for example, CrunchIt.PPC3_ARM.CAB 

for XScale and ARM devices) found in the CrunchIt folder.
2. Copy or download the .CAB file to your device.
3. Open Microsoft File Explorer (Start > Programs > File Explorer).
4. Locate and tap the CrunchIt .CAB file.
5. Follow the on-screen instructions.

Uninstalling
Perform the following steps to uninstall CrunchIt.

1. If CrunchIt is running, exit the application.
2. Open Microsoft ActiveSync on your desktop computer.
3. Select the Add/Remove Programs option in the Tools menu.
4. Select NSC CrunchIt in the application list.
5. Click the Remove button.
6. Follow the on-screen instructions.
CrunchIt User Guide



CHAPTER 5 Configuring CrunchIt
CrunchIt includes many options to help you work with archives. To configure 
CrunchIt, select the Settings option in the Tools menu.

Configure General settings

1. Open folder. Enter the default archive folder. 
CrunchIt will always look for files in this location.
2. Extract folder. Enter the default extract or tempo-
rary folder.
3. Add folder. Enter the default folder for add opera-
tions.
4. Confirm delete prompt. Check this option if you 
want to CrunchIt to ask you if it is okay to delete any 
files or folders.
5. Close dialogs. Check this option if you want to 
automatically close status dialogs.

6. Benchmark ZIP operations. This option will cause CrunchIt to display perfor-
mance statistics after every ZIP operation. See the “Benchmarking ZIP opera-
tions” section below.

7. Hide password. Enable this option if you do not want to make your passwords 
visible while you enter them.
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Configure Compression settings
1. Overwrite existing files. Check this option 
if you want the files and folders in the current 
archive to always overwrite the ones on your 
device. 

WARNING: This option will override the Skip 
older file(s) option and may delete any 
changes you have made to existing files.

2. Skip older files. Select this option if you 
want CrunchIt to preserve newer files on your 
device.
3. Ignore path information. Check this 
option if you want to ignore the folder hierar-
chy in the current archive.

4.  Refresh older files. This option will update the files in your archive.
5. Move files to archive. Select this option if you want CrunchIt to delete the files 

on your device after they have been moved into the archive.
6. Compression level. Adjust the pointer to the compression level that suits your 

needs. None or fast compression levels will take less time, but result in larger 
archives.
CrunchIt User Guide



CHAPTER 6 Using CrunchIt
Opening Archives
There are two methods to open an archive with CrunchIt:

Microsoft File Explorer
Open Microsoft File Explorer (Start > Programs > File Explorer) on your device 
and browse to the folder where you store your archive files. Single-tap a ZIP, SFX, 
TAR, GZIP, BZIP2 or JAR file. 
CrunchIt User Guide 11
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CrunchIt
Open CrunchIt (Start > Programs > CrunchIt) and 
select the Open Archive option in the File menu, or sin-
gle tap the folder icon on menu bar. The 'Open' dialog 
will be displayed.

The Open dialog (right) allows you to access the 
archives on your device. If you want to change folders, 
double-tap an entry in the folder view or select an entry 
in the Folder dropbox. You can filter archives with the 
Type options; and sort based on name, size and date. 

To open an archive, double tap an entry in the file view, 
or select it and tap the Open button.

Viewing Files And Folders
CrunchIt provides two different views to display file and folder information:

The Tall View
The Tall view uses two lines to display filename, date, 
size and compression (or file type if the compression 
data is not available) information. This view is designed 
to: 

• Make reading long filenames (with extensions) eas-
ier. 

• Distinguish between application icons.
• View the compression ratio or file type.
• The extra area of each item allows users to accurately 

tap and select files.
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Viewing Files And Folders
The Short View
The Short view lets you view the maximum number of 
file entries on your Pocket PC display. It can help you 
identify groups of files and avoid a lot of scrolling.

Viewing File Properties
You can view file and folder information by selecting an 
entry and choosing the File Properties option (Edit > 
File Properties... or ‘tap and hold’). Note the expanded 
file size and compression ratio is not available for all 
types of archive formats.
CrunchIt User Guide 13
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Navigation Options

The Navigation Toolbar
The Navigation toolbar lets you select the current folder, change the display mode 
and search for files and folders.

The Folder Dropbox
The Folder dropbox lets you navigate to a previous or parent folder. Tap the control  
to view the contents and select a folder entry. The current selection is indicated with 
a dot.

The Parent Folder Button
The Parent Folder button works with the Folder dropbox. Tap this button to to 
move to the parent folder.
CrunchIt User Guide



Working With Files And Folders
How To Change Folders
You can view the contents of a folder by double tapping (single tap is used to 
select) any folder entry.

Working With Files And Folders
CrunchIt User Guide 15
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Selection Modes
CrunchIt has two different modes for selecting files: single and multi mode. In sin-
gle select mode, every time you select a new file or folder (by tapping it) your pre-
vious selection will be deselected. In multi-select mode, you can select multiple 
entries by tapping each one.

Launching Files
Double tap a file (or Edit > Open) to automatically extract and open it in the asso-
ciated Pocket PC application. For example, a .doc file will be loaded into Pocket 
Word.

E-mailing Files
You can email a selected file to a friend by choosing the Mail File... option in the 
Edit menu.

Searching For Files And Folders
To search and select files, choose the Find option in the 
Edit menu. Enter a name pattern (all UNIX wildcard 
options are supported, such as ?, * and !).

Testing And Extracting Files
To extract files from an archive, select the Extract option in the Edit menu; or 
click the arrow icon (see above) on the tool bar. The 'Extract File(s)' dialog will be 
displayed; containing options to change the destination folder of the files, overwrite 
mode and selection criteria. Tap Extract to decompress and write the contents of 
the files.
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Working with ZIP files
If you wish to test the integrity of an archive or specific files, use the Test option 
found in the Edit menu. CrunchIt will decompress and check the file data without 
writing the contents.

If one or more of the files in the archive is protected with a password, CrunchIt will 
prompt you for a password to unlock the contents.

The default file selection behavior of test and extract is as follows. If no files are 
selected the operation will apply to all files, otherwise selected files will be used.

Working with ZIP files

Creating New ZIP Files
To create a new ZIP archive, select the New Archive 
option in the File menu. The 'New ZIP' dialog will be 
displayed; where you can enter the name and location of 
the new archive. Note that do not need to add the '.zip' 
extension to the name, CrunchIt will add it for you. Tap 
Create or press return to edit the new archive.

Adding Files
To add files to a ZIP archive, select the Add option in 
the Edit menu or tap the plus icon on the tool bar. The 
'Add File(s)' dialog will be displayed; containing 
options to select the files or folders to be compressed.

Notes:

•  If you select a folder, the add operation will apply to 
all of the files and sub-folders contained in it.
CrunchIt User Guide 17
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•  A file Mask option is available to add files of a specific name or type. For 
example, '*.doc' will cause CrunchIt to only add word processing documents to 
the archive. 

Tap the Add button to insert the selected files and folders to the archive.

Securing Files With A Password
To encrypt files with CrunchIt, you must enter a 
password before adding items to the ZIP file:

• Select the Password option in the Tools menu.
•Enter a password and tap 'OK' to continue.
•Add (Edit > Add) files to the archive.

NOTE: CrunchIt uses the ZIP 2.0 encryption 
standard (Windows, Unix and Macintosh com-
patible) to encode files.

Deleting Files And Folders
To delete files and folders from an archive, select one or more entries in the file 
view. Choose the Delete option in the Edit menu or tap the 'X' icon in the menu bar. 

NOTE: Users have reported that the delete operation will fail on some storage 
cards and devices. This is a bug in the operating system/device driver. If you are 
experiencing problems, you should move the file off the storage card, perform the 
delete operation and then move it back.

Benchmarking ZIP operations
NOTE: This feature is for registered users.

CrunchIt includes a benchmarking tool for measuring the performance of your 
PDA’s processor and storage devices.
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Creating Self-extracting ZIP Files
To benchmark the performance of ZIP operations, check the Benchmark ZIP 
operations option in the General settings (Tools > General).

NOTE: If you turn on the benchmarking feature, you will have to close the current 
ZIP file and re-open it to gather performance statistics.

Stream Statistics
The inflate/deflate statistics display the amount of time (seconds) the processor 
spends performing dictionary lookups, bit shifting/arithmetic and  read/write mem-
ory operations. If the data is encrypted, additional CRC calculations and arthimetic 
are included. These measurements do not account for the time taken to read or write 
to the file system.

File Statistics
The read/write statistics display the amount of time spent reading and writing data 
from the storage device.

General Statistics
The archive statistics display the amount of time spent processing the archive for-
mat datastructures. It does not account for the time taken to update the CrunchIt 
user interface or threading overhead.

Creating Self-extracting ZIP Files
The first step in creating a self-extracting ZIP file is to 
create a regular ZIP file with the files and folders you 
want to include in the final executable.

NOTE: Do not use a password in your ZIP file, the self-
extracting component does not support encrypted ZIP 
files.

After you have created your ZIP file, select the Convert 
To .EXE option in the File menu:

1. Tap the Browse button and select the source ZIP file.
CrunchIt User Guide 19
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2.  Select the target platform:
•  Pocket PC (PPC 2000), 
• Pocket PC 2002 (PPC 2002) or
•  Windows Mobile (PPC 2003) .
3.  Check the platforms (ARM, MIPS etc.) you want to target. CrunchIt will gener-

ate a file for each platform. Note that XScale processors use the ARM target. 
4. Tap the OK button.

CrunchIt will generate the self-extracting ZIP files in the same folder as the source 
ZIP file. It will append the platform name and “.exe” extension to the file. For 
example, app.zip will become appARM.exe or appSH3.exe.

SFX Applications
Self-extracting ZIP files can be used for many applications:

• Software installation.
• Version control. Save the time and effort required to shuffle single files around.
• System recovery solutions (restore applications and data).
• Automated scripts. 
• Data deployment (where users do not have to own compression utilities).
• Compact e-mail attachments.
• Plus many more.
CrunchIt User Guide



Creating Uuencoded Files
Creating Uuencoded Files

If you want to send and receive binary files from news-
groups or other Internet services, you will need to 
become familiar with uuencode. This format takes any 
file on your Pocket PC and produces an encoded (using 
only ASCII characters) version suitable for plain-text 
transport.

To create a uuencoded file, select the UUEncode File 
option in the Tools menu:

1. Tap the Browse button and select the source file.
2. If the source file is too big (over 500K) to fit into a sin-

gle message, select the Split (“Split file into multiple parts”) option. See step 3.
3. If you have selected the Split option, enter or select the maximum number of 

lines per message. You should enter atleast 10 lines.
4. If you want to use base64 encoding, check the “Use base64 encoding” option.
5. Tap OK to create the UUE file(s).

CrunchIt will generate a UUE file in the same folder as the source file. It will name 
files with the following convention:

filename-extension[(part-total)].UUE

The part-total information is present when the Split option is selected, otherwise it 
is omitted. 

NOTE: The Windows CE (Pocket PC) operating system does not allow the forward 
slash character (‘/’) in filenames.
CrunchIt User Guide 21
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Decoding Files
To combine and decode files from newsgroups or 
email, select the Combine/Decode option in the 
Tools menu:

1. Tap the Add button to select files to decode.
2. To change the order of files, select the file-
name in the listbox and use the Up and Down 
buttons.
3. Tap OK to combine and decode the files.

How To Create And Edit A Shortcut
On your Pocket PC:

1. Open Microsoft File Explorer.
2. Find and select the file you want to create a Shortcut for.
3. Select the Paste Shortcut option in the Edit menu. A file with the prefix 

“Shortcut to” and the extension “.lnk” will be created.

On your Microsoft Windows PC:

1. Open Windows Explorer.
2. Locate the Mobile Device folder (located under “My Computer”).
3. Find and select the Shortcut file (.lnk) you created on your Pocket PC.
4. Copy this file to a location on your Windows PC.
5. Open Notepad (Start > Run > Notepad).
6. Edit the Shortcut (see instructions below) using Notepad (File > Open).
7. Copy the Shortcut file back to your device.
CrunchIt User Guide



How To Create And Edit A Shortcut
Pocket PC Shortcut Format
The Shortcut file format provides a simple interface to run applications with custom 
parameters. It can be edited in any text editor and uses the following rules:

<number of chars after ‘#’>#<“application path and file name”>[<space>option1 
[<space>option 2]...]
CrunchIt User Guide 23
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CrunchIt Command Line Options (registered version)

NOTE: If the optional parameters are not specified, the CrunchIt defaults (the set-
tings in the configuration pages) will be used.

COMMAND STATE DESCRIPTION/SYNTAX

/archive <filename> Required Archive to open/create.

/extract Required Extract files and folders (cannot be 
mixed with add or test).

/test Required Test archive integrity (cannot be 
mixed with extract option).

/add Required Add files to archive (cannot be mixed 
with extract or test).

/folder <pathname> Optional Specify destination folder (for extract 
operations).

/file [file 1 [file 2] ..]] Optional Specify files for add operation. Use 
quotes (“\file1.doc” “\file2.doc”) and 
a space to separate multiple files.

/ignorepath [on | off] Optional Ignore path information during 
extraction process.

/skip [on | off] Optional Skip older files during extraction pro-
cess.

/level [0-9] Optional Set compression level (for add opera-
tions).

/move [on | off] Optional Move files to archive (for add opera-
tions).

/refresh [on | off] Optional Refresh older files (for add opera-
tions).

/password <alphanum> Optional Password required to extract/add files.

/prompt [on | off] Optional Turn status dialogs, and error mes-
sages on/off.

/overwrite [on | off] Optional Overwrite existing files during the 
extraction process.

/exit Exit after extraction process is com-
plete.
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How To Create And Edit A Shortcut
CrunchIt Examples
The following Shortcut will add all of the files in “My Documents\Templates” to an 
archive named “mytemplates.zip.”

138#"\Program Files\CrunchIt\CrunchIt.exe" /archive "\My Documents\mytem-
plates.zip" /prompt off /move off /add /file "\My Documents\Templates"

The next example will automatically extract the archive “\My Documents\mytem-
plates.zip” to the “\Temp” folder and exit.

151#"\Program Files\CrunchIt\CrunchIt.exe" /archive "\My Documents\mytem-
plates.zip" /prompt off /overwrite on /ignorepath on /extract /exit /folder "\Temp"

SFX Command Line Options

SFX Example
The following Shortcut will extract the files in the SFX named “testARM2003.exe” 
to the “\Temp” folder and automatically exit.

57#"\My Documents\testARM2003.exe" /auto /folder Temp /exit

COMMAND DESCRIPTION/SYNTAX

/auto Automatically start the extraction process.

/folder <path> Extract to specified folder. Default is “\My Documents”.

/exit Exit after extraction process is complete.
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CHAPTER 7 Support
To find current information on CrunchIt, please monitor our website at:

 http://www.nsctech.com

If you have purchased this software and require assistance, please contact:

support@nsctech.com

Sales and reseller information should be directed to:

sales@nsctech.com

We like to hear what you think of our products! If you have any comments or fea-
ture requests for CrunchIt, email them to:

support@nsctech.com
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